Magic Launcher 1.7.5/1.7.4/1.7.2/1.6.4 for Minecraft

Magic Launcher is a new Minecraft launcher which can load mods dynamically without changing or patching the minecraft.jar. No more mod installation problems, just select your mods and enjoy!

Features

Minecraft

  • selectable minecraft.jar
  • automatic version detection
  • configurable window size, also maximized
  • selectable minecraft folder
  • selectable java executable
  • java memory limit
  • java custom parameters
  • show error log
  • remember user
  • configuration profiles

Mods

  • load mods dynamically without changing minecraft.jar
  • META-INF does not have to be deleted
  • automatic mod compatibility checking
  • external mods detection and compatibility checking
  • shortcut to external mods folder
  • configurable external mods
  • automatic mod requirements checking (ModLoader, ModLoaderMP, Forge, GuiAPI)

Design

  • Minecraft style

News

  • Minecraft
  • Reddit
  • Twitter
  • Blogspot …

 Minecraft Magic Launcher

Magic Launcher 1.7.5/1.7.4/1.7.2/1.6.4 ToDo

  • Check for new Minecraft version and update Minecraft
  • Tooltips
  • Incremental GC (-XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode)
  • Support for Coremods folder
  • Mojang server status
  • Configurable news tab
  • Export mod list
  • Auto login
  • Security
  • Drag and drop
  • Languages
  • Multiple accounts
  • Command line options
  • Mods with a subdirectory root
  • Detect libraries (TurboModelThingy)
  • Better conflict detection
  • Portable, relative paths
  • Limit worlds per profile
  • Minecraft font
  • Backups
  • Downgrade/upgrade minecraft
  • Support for patchers

Magic Launcher 1.7.5/1.7.4/1.7.2/1.6.4 Download Link

For : [Windows], [Mac], [Windows/Mac/Linux]

Mirror: [Windows], [Mac], [Windows/Mac/Linux]

Old Downloads: HERE

If this don’t work, tray to install Modloader first.

Note for Minecraft 1.6.2+

To run Minecraft 1.6.2+, go to Setup -> Environment and select 1.6.2. If the Environment 1.6.2 is not available, use the vanilla launcher to download and start Minecraft 1.6.2, then Environment 1.6.2 should appear in the list.

To run Minecraft 1.6.2+ with Forge, go to Setup -> Environment and select 1.6.2_Forge_XYZ. If the Environment 1.6.2_Forge is not available, use the vanilla launcher to download and start Minecraft 1.6.2, then use the Forge installer to install Forge and then the Environment 1.6.2_Forge_XYZ should appear in the list.

Changelogs:

  • v1.2.5 updated for Minecraft 1.7.4
  • fixed missing sound, caused by the sound thread being interrupted while writing log. Fixed Forge mod detection when Forge is loaded as environment library. Fixed RSS feeds to use cached static files.

Credits and big thanks to sp614x.

Comments

Tags: , , , , , , , , , , , , , , , , , , , ,

Category: Minecraft Mods